交换机VLAN划分实验

浏览:
字体:
发布时间:2013-12-10 00:03:40
来源:东方联盟
交换机VLAN划分实验
 
基础知识:
 VLAN是虚拟局域网(Virtual Local Area Network)的简称,它是在一个物理网络上划分出来的逻辑网络。这个网络对应于ISO模型的第二层网络。VLAN的划分不受网络端口的实际物理位置的限制。VLAN有着和普通物理网络同样的属性,除了没有物理位置的限制,它和普通局域网一样。第二层的单播、广播和多播帧在一个VLAN内转发、扩散,而不会直接进入其他的VLAN之中。
   
   划分策略:
      1)基于端口的vlan
      2)基于MAC地址的vlan
      3)基于路由的vlan
      4)基于策略的vlan
 
1、实验目的
(1)学习交换机的VLAN划分配置
2、实验内容
      //(1)超级终端登陆交换机
      //(2)交换机基本配置
(3)配置VLAN
3、实验环境
    PC机、交换机各一台,线路若干
4 、实验拓扑图
 
 
5.实验步骤
(1)交换机基本配置
Switch>enable(由用户模式进入到特权模式)
Switch#configure terminal(进入全局配置模式)
Switch(config)#interface Vlan 1
ip address 192.168.2.2 255.255.255.0 
(no ip address 192.168.2.2 255.255.255.0)
no shutdown
exit
Switch#show run (查看配置信息)
主机的IP地址配置成同一网段的
PC1: 192.168.1.2
PC2: 192.168.1.3
测试:PC1 ping PC2
 
2)在交换机上创建VLAN 
    创建vlan并命名
         Switch#configure terminal
    Switch (config)#vlan 3  (创建vlan 3)
    Switch(config-vlan)#name vlan3
    Switch (config)#vlan 4  (创建vlan 4)
    Switch(config-vlan)#name vlan4
    Switch (config-VLAN)#exit
    将端口加入vlan
    Switch (config)#interface FastEthernet 0/1
    Switch (config-if)#switchport mode access
    Switch (config-if)#switchport access vlan 3  
    Switch (config-if)#exit
    Switch (config)#interface FastEthernet 0/4
    Switch (config-if)#switchport mode access
    Switch (config-if)#switchport access vlan 4
    Switch (config-if)#exit
测试
 PC1 ping PC2
Switch#show vlan
查看vlan配置结果 Switch#show vlan
VLAN Name                        Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                            active    Fa0/3, Fa0/2, Fa0/5, Fa0/6
                                                            Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                            Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                            Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                            Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                            Fa0/23, Fa0/24, Gig1/1, Gig1/2
10   VLAN0010                     active    Fa0/1
20   VLAN0020                     active    Fa0/4
1002 fddi-default                 act/unsup 
1003 token-ring-default      act/unsup 
1004 fddinet-default            act/unsup 
1005 trnet-default                act/unsup
 
(3)删除VLAN
删除VALN,需要先删除VLAN下接口:
Switch>enable  进入特权模式 
Switch#configure terminal  进入全局配置模式
Switch(config)# interface fastethernet0/1
Switch(config-if)# no switchport access vlan 3
Switch(config-if)# exit
再删除VLAN
Switch(config)# no vlan 3 (vlan 4 )
查看删除情况
Switch#show vlan  
配置VLAN——创建VLAN
 
方法一:
                  步骤1:进入全局配置模式
                    Switch#configure terminal
                  步骤2:创建VLAN
                    Switch(config)#vlan vlan-id
                  步骤3:(可选)命名VLAN
                    Switch(config-vlan)#name vlan-nam
方法二:
             步骤1:进入特权配置模式
                       Switch>enable
                  步骤2:创建VLAN
                    Switch_A#vlan database
             步骤3:(可选)命名VLAN
                    Switch_A(vlan)#vlan 2 name VLAN2
 
配置VLAN——将端口加入VLAN
步骤1:进入端口配置模式
Swtich(config)#interface interface
步骤2:将端口模式设置为接入端口
Switch(config-if)#switchport mode access
步骤3:将端口添加到特定VLAN
Switch(config-if)#switchport access vlan vlan-id
 
配置VLAN——将端口加入VLAN
示例:将端口FastEthernet 0/1加入VLAN
Switch#configure terminal
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#end
 
 
配置VLAN——将一组端口加入VLAN
步骤1:进入到一组需要添加到VLAN的端口中
Swtich(config)#interface range interface-range
步骤2:将端口模式设置为接入端口
Switch(config-range-if)#switchport mode access
步骤3:将一组端口划分到指定VLAN
Switch(config-range-if)#swtichport access vlan vlan-id
 
示例:将端口fastEthernet 0/1~5,0/7同时划分到VLAN10
Switch#configure terminal
Switch(config)#interface range fastEthernet 0/1-5,0/7
Switch(config-if-range)#switchport mode access 
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
 
>更多相关文章
24小时热门资讯
24小时回复排行
资讯 | QQ | 安全 | 编程 | 数据库 | 系统 | 网络 | 考试 | 站长 | 下载 | 关于东盟 | 安全雇佣 | 搞笑视频大全 | 微信学院 |
关于我们 | 联系我们 | 广告服务 | 人才招聘 | 服务条款 | 免责申明 | 帮助中心 | 作品发布 | 网站地图 | 技术培训
Copyright © 2007 - 2018 Vm888.Com. All Rights Reserved
东方联盟 版权所有