TP-Link WR703N路由器刷机教程

浏览:
字体:
发布时间:2013-12-10 00:03:43
来源:东方联盟

首先我们要了解我们刷的路由器是啥芯片,这个TL-WR703N的硬件条件如下:
TP-Link WR703N
The TP-Link router is a small wifi hotspot, with a USB port that make highly customizable. Moreover, this unit cost less than 100RMB on your favorite online shop!
Specifications :Atheros AR7240 CPU (400Mhz)Atheros AR9331 Chipset (integrated wireless)802.11 b/g/n 150Mbps (130Mbps real)wireless power output 20dBm – 100mW4 MB flash memory32 MB RAMTiny form factor: 5.7cm x 5.7cm

1x LAN port1x USB 2.0 port1x mini USB port, for power1x LED (customisable once OpenWRT is installed)
芯片是Atheros AR7240 CPU,400MHz的主频,很不错了哦~100块钱很划算(不过要小心被刷成砖头哦。。)
为了能刷机,首先要下载最新的703N的openwrt版本文件:http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
文件大小为:3.75M,很容易就下载好了
接下来就要准备好一根网线和一根迷你usb线(电源线),然后接上电脑,这个接线不用描述了吧,所有口都是唯一的,不对是插不进去…
接下来设置已连接电脑或者笔记本的IP为192.168.1.100,子网掩码255.255.255.0,默认网管192.168.1.1
(其实就用DHCP就好了。。囧)
网络邻居那里查看网络时候已经连接上,当然最好先看看路由器的电源灯是否亮着的..
打开浏览器输入192.168.1.1就可以进入到路由器的原本系统中去了,如图:
 
 
密码是admin,一般不会错,错了就恢复出产设置…
进入之后,点左边的系统工具–>软件升级
 
当前软件版本:
3.15.2 Build 130321 Rel.37153n
当前硬件版本:
WR703N v1 00000000
在这里我们可以看到当前系统的版本和硬件版本
在文件处,选中我们刚才下载的bin文件,然后点升级
确认下就可以升级了,大概升级用了30s就搞定了吧
(在这个期间切记不要断电以及断开网线,否则后果有些麻烦)
完成后使用telnet 192.168.1.1登陆路由器,如果你是windows7或者windows8,那么你要telnet你可以下载其他软件或者打开原本的系统工具
方法嘛:(我这里是windows8)
打开后,进入ms-dos状态,输入telnet 192.168.1.1
 
搞定了,哈哈
这时需要修改下密码,以便以后能够ssh登陆,就是为了能够远程登陆访问,ssh是一个很方便的东东哦
passwd
修改完密码后即可使用putty或者其他远程登陆工具ssh连接上路由器了
效果图:
但是吧,它毕竟是个路由器吖,这个虾米全是文字界面,很是让人不爽,所以我继续下面的安装,GUI luci界面
在安装GUI luci界面前,我们需要先配置好该路由器的wifi功能,否则没有办法升级呢
在putty中输入
vi /etc/config/network
打开了网络配置文件后,按i对文件进行修改,在最下面添加
config interface ‘wan’
option ifname ‘wlan0′
option proto ‘dhcp’
 
 
如图:
 
完成后输入
:wq
这里不要忘记了冒号,这个vi编辑器,不熟悉还挺难用的,但熟悉了之后还是很不错的,不过我比较喜欢vim,哈哈
继续修改
vi /etc/config/wireless
将无线设置修改如下:
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option path ‘platform/ar933x_wmac’
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1config wifi-iface
option device radio0
option network wan
option mode sta
option ssid ’211-abcdefg’
option encryption ‘psk2′
option key ’211-1234′
 
这里的wifi配置是用来配置你的无线网络的,因为要更新,所以703N就变成一个开发板一样连接到你的wifi网络中去
其实也可以直接用网线连你原本上网的路由器也可以的,配置好网络即可
修改好后,保存退出
:wq
要无线生效,还需要重启下才行
reboot
重启还需要几秒钟,如何知道它启动成功了呢?
通过msdos下的ping命令
 
重新登陆后,查看下是否获得ip
 
已经获取到了ip了,测试下网络连接
发现能ping通8.8.8.8,却不能ping www.baidu.com
说明dns没有设置好,但并不影响升级
输入
opkg update
 
opkg install luci
过程如下:
完成后输入下面的命令:
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
这里是为了启动uhttpd服务,关于这个服务嘛,我猜测,只是猜测,它是apache的移植,是用来让我们用ip 192.168.1.1网页访问的
Ok后reboot即可完成刷机。
话说一次就刷机成功了,哈哈,不过这太没技术含量了,我们要做的是完全定制,添加自己想要的功能
不过别急,这才是开始,this is just beginning.
>更多相关文章
24小时热门资讯
24小时回复排行
资讯 | QQ | 安全 | 编程 | 数据库 | 系统 | 网络 | 考试 | 站长 | 下载 | 关于东盟 | 安全雇佣 | 搞笑视频大全 | 微信学院 |
关于我们 | 联系我们 | 广告服务 | 人才招聘 | 服务条款 | 免责申明 | 帮助中心 | 作品发布 | 网站地图 | 技术培训
Copyright © 2007 - 2018 Vm888.Com. All Rights Reserved
东方联盟 版权所有